home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / sys-apps / iproute2-2.6.11.20050310-r1 / iproute2-2.6.11.20050310-r1.ebuild < prev    next >
Text File  |  2005-10-18  |  2KB  |  77 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-2.6.11.20050310-r1.ebuild,v 1.7 2005/07/17 13:42:52 dertobi123 Exp $
  4.  
  5. inherit eutils toolchain-funcs
  6.  
  7. MY_PV=${PV%.*}
  8. SNAP=${PV##*.}
  9. SNAP=${SNAP:2}
  10. DESCRIPTION="kernel routing and traffic control utilities"
  11. HOMEPAGE="http://developer.osdl.org/dev/iproute2/"
  12. SRC_URI="http://developer.osdl.org/dev/iproute2/download/${PN}-${MY_PV}-${SNAP}.tar.gz"
  13.  
  14. LICENSE="GPL-2"
  15. SLOT="0"
  16. KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sparc x86"
  17. IUSE="atm berkdb minimal"
  18.  
  19. RDEPEND="!minimal? ( berkdb? ( sys-libs/db ) )
  20.     atm? ( net-dialup/linux-atm )"
  21. DEPEND="${RDEPEND}
  22.     >=virtual/os-headers-2.4.21"
  23.  
  24. S=${WORKDIR}/${PN}-${MY_PV}
  25.  
  26. src_unpack() {
  27.     unpack ${A}
  28.     cd "${S}"
  29.     epatch "${FILESDIR}"/${P}-dsmark-qdisc.patch #86729
  30.     sed -i -e "s:-O2:${CFLAGS}:" Makefile || die "sed Makefile failed"
  31.     #68948 - esfq/wrr patches
  32.     epatch \
  33.         "${FILESDIR}"/2.6.9.20041106-esfq.patch \
  34.         "${FILESDIR}"/2.6.9.20041019-wrr.patch
  35.     # don't build arpd if USE=-berkdb #81660
  36.     use berkdb || sed -i '/^TARGETS=/s: arpd : :' misc/Makefile
  37.     # Multilib fixes
  38.     sed -i 's:/usr/local:/usr:' tc/m_ipt.c
  39.     sed -i "s:/usr/lib/tc:/usr/$(get_libdir)/tc:g" \
  40.         tc/Makefile tc/tc.c tc/q_netem.c || die
  41. }
  42.  
  43. src_compile() {
  44.     echo -n 'TC_CONFIG_ATM:=' > Config
  45.     use atm \
  46.         && echo 'y' >> Config \
  47.         || echo 'n' >> Config
  48.  
  49.     local SUBDIRS="lib ip tc misc"
  50.     use minimal && SUBDIRS="lib tc"
  51.     emake \
  52.         CC="$(tc-getCC)" \
  53.         AR="$(tc-getAR)" \
  54.         SUBDIRS="${SUBDIRS}" \
  55.         || die "make"
  56. }
  57.  
  58. src_install() {
  59.     if use minimal; then
  60.         into /
  61.         dosbin tc/tc || die "minimal"
  62.         return 0
  63.     fi
  64.  
  65.     make \
  66.         DESTDIR="${D}" \
  67.         SBINDIR=/sbin \
  68.         DOCDIR=/usr/share/doc/${PF} \
  69.         install \
  70.         || die "make install failed"
  71.     if use berkdb ; then
  72.         # bug 47482, arpd doesn't need to be in /sbin
  73.         dodir /usr/sbin
  74.         mv "${D}"/sbin/arpd "${D}"/usr/sbin/
  75.     fi
  76. }
  77.